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Introduction 
 

Easymnemo is vector graphics application to create diagrams, charts. You can use diagrams in your 

documents, presentations, promotional materials, business cards, etc. The program contains a large library of 

symbols and elements, including product images of popular manufacturers of equipment, image graphic 

symbols from GOST, ABOK. A lot of attention has been paid to the heat supply, water supply, gas supply, 

Automated Process Control System. The program gives the possibility to print prepared by the scheme, 

export them to bitmap files. 

 

Installation kit contains the catalog of examples (schemes of measurement of heat energy, water, gas, 

heating, connection schemes of boiler equipment, switching schemes, structural schemes, schemes of 

computer networks, schemes of burglar fire alarm, advertising materials, business cards, etc.). 

 

Easymnemo allows you to store text information in several languages for one scheme. User can easily 

change the color scheme, to choose volumetric or flat style of image, add shadows, etc. The Easymnemo 

Interface and most of the examples translated into Russian, English, Spanish and Czech languages. 

 

Program is easy to use and intuitive. Nevertheless, there are not very obvious points that this document will 

help you clarify. 

 

 

Interface language 
 

Select a language from the list in the upper right corner of the window of the program: 

 

 
 

Note: All the examples included in the installation kit, translated into Russian and English languages, and 

many in Spanish and Czech. Changing the interface language will display examples in accordance with the 

established language (examples, which not translated into Spanish, Czech or Italian, will display at the 

English language).  
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Editing 
 

After starting, the program is in the selection mode. The mouse pointer is in the form of a cursor. The left 

part of the program window contains the toolbox (collection of symbols). After clicking on the item icon, the 

program will enter the mode of inserting a new object. The mouse pointer will take the crosshair form. 

 

 
 

To add an object to the diagram, press the left mouse button on the diagram and drag the mouse pointer. 

After you release the left mouse button, the object will appear on the diagram. The program will remain in 

the insert mode of the new object (the mouse pointer will also remain in the crosshair form) and you can add 

the object again. 

 

To return to the selection mode, click the Cursor icon or right mouse button or any key. The mouse pointer 

will take the cursor form. In the selection mode, you can edit the added objects. 

 

► Starting from version 2.19.06.18, one more way to insert a new object is added - by double-

clicking on the corresponding icon. For objects that can be placed on pipes (fittings, filters, flow 

meters, etc.), the initial dimensions of the created object will be set by the program based on the 

current diameter of the pipe. For other the initial dimensions will be set by the program based on the 

base size of the element. The original current pipe diameter and the base element size can be set in 

the in the Picture properties dialog box.  

 

Note that the current diameter of the pipe can change when working with the scheme, for example, 

you have selected a different diameter pipe, and the program remembers this value. The base size of 

the element can be set in the Picture properties dialog box. 

 

Comment. If the current pipe diameter is less than the minimum value (the default is 5 px; can be set 

in the Picture Properties dialog box), the pipe diameter for the object size calculation is assumed to 

be this minimum value. 

 

To start editing an object, select the object by click the left mouse button on the object. After that, you will 

have access to the toolbar for editing the properties of objects (fill, lines, rotation, etc.) and the toolbar 

responsible for the position and alignment of objects. 

The mouse pointer is in 

the insert mode of a new 

object 

Toolbar – “objects 

properties” 

Toolbar – “location of 

objects” 

Toolbox 
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Note 1: There are several ways to select multiple objects: 

 

 Holding the Shift key click the left mouse button on the objects. If the object clicked on is not already 

selected, it will be selected. If it is already selected, it will be deselected; 

 Press the left mouse button on the free space of the diagram and drag the cursor. Objects will 

selected, that fall into the field of the displayed rectangle; 

 You can select all objects by using Edit > Select all menu. 

 

To move a object: position the pointer over the object. Hold down the left mouse button and drag the object. 

You can also move selected objects by using the Shift / Arrow Keys. 

 

Note 2: After selecting an object, the program “remembers” some properties of the selected object: colors, 

border parameters, pipe diameter, etc. When you insert a new object, the program uses this data to give the 

new objects the appropriate properties. For example, if you select a pipe, a new pipe will be added with the 

same diameter, color, and thickness of the boundary lines as the selected pipe. 

 

Note 3. ► Starting from version 2.20.05.15, a layout grid has been introduced (in 0.1 cm increments by 

default). When moving objects will coordinate their position with her. Namely: each object has a certain 

conditional center, which will be combined with the nearest node of the layout grid. You can change the 

properties of the layout grid and also discard it in the Settings> Parameters dialog box. 
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Toolbar “Objects properties” 

 

 
 Fill 

 Lines 

 Additional color 

 Text and text attributes (font, size, color, alignment) 

 Text 

 Comment 

 Shadow 

 Specification 

 Dot-dashed line 

 Flanges, connections, stoppers 

 Pipeline nodes and diameter 

 Line stoppers 

 Table 

 Keys 

 Parallel lines 

 Anchor (binding of the extreme nodes of the tubes or lines to objects) 

Rotation: 

 Counterclockwise (default 15°)  Clockwise (default 15°)    At an arbitrary angle 

 Flip horizontally     Flip vertically 

 Isometric projection 

 Group/Ungroup 

 Assemble model/Disassemble model 

 

 

Toolbar “Objects location” 

 

 
Alignment of selected objects: 

 Align to layout grid  Left align  Right align  Top align   Bottom align 

 

Size alignment of selected objects: 

 Min width  Max width  Min height  Max height 

 

Order in which objects appear: 

 Bring to front  Send to back  Bring forward  Send backward 

 

 Align to pipe and attach 

 Set object size by pipe diameter 

 Lock 

 Format painter 

 Clone 

 Delete 
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The selected object has corner handles  (brown 

markers). Drag a corner handle until the object is the 

size you want. 

 

The group of selected objects has corner handles  

(black markers). Drag a corner handle until the group 

is the size you want. 

 
 

 

You can also change the size of the selected objects by using keyboard shortcuts: 

 Shift / + , Shift / - , Shift / PageUp , Shift / PageDown 

 

Note 1: Some objects require a valid width to height ratio. For some objects, the height must be greater than 

the width (or part of it), for others, on the contrary, the width is greater than the height (or part of it). If you 

do not observe the "proportions" - a rectangle is drawn. The following picture shows what will happen to 

one of these objects if you constantly increase its width. 

 
Note 2: When you resize selected object, if you hold Shift key, the selected object will be resized 

proportionally. 

 

Note 3: For some objects, it is possible to change the “geometry” using special handles  (yellow markers): 

 

 
 

Drag a yellow handle until the object is the "geometry" you want. For example, 
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Pipes 
The program provides two types of pipes (ducts): with diameter and without diameter. A pipe without a 

diameter is a polyline for which a dimension is specified that determines the height of the “pipe ends” and 

the elements that can be placed on the pipe. In this sense, the size plays the same role as the diameter of 

"ordinary" pipes. 

 

  

 

 
 

For example, drag a 

yellow handle up 

Pipe icons without 

diameter 

Pipe icons with a 

diameter 

Example of a pipe without 

diameter 

Example of pipe with a diameter 

Example of a pipe without 
diameter 

 

Example of pipe with a diameter 
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1. To draw pipe with horizontal/vertical segments, click the "Right angles" flag on context menu. 

 

   
 

 

2. To add a new pipe segment, select the pipe node (click on the node - it will change color from brown to 

yellow) and press the Insert key (or select Add node on context menu). 

 

 

 

 

 

 

3. To delete a pipe segment, select the pipe node and press the Delete key (or click Delete on context menu). 

 

 

1. Click the node 

2. Right-click on 

the pipe to open 

context menu 

1. Right-click on the 

pipe to open the 

context menu 2. Check the Right 

angles 

3. Click Add Node  
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4. To bind an extreme pipe node to an object: select the node, move the node on the object and click the 

button  (or set the Anchor flag on context menu). 

  

 
 

5. To change the diameter of the pipe, diameter, and color of individual segments of pipe and the type and 

size of pipe nodes click the button  (or click Nodes and Diameter on context menu). Set your desired pipe 

diameter, segment diameter, node diameter, insulation, flanges and gaskets in the pop-up dialogue box. 

 

  
 

 

1. Click the pipe node 
2. Click Anchor button 
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The following examples illustrate the results of the changes in the Nodes and Diameter dialogue box: 

 
 

 

6. To change the pipe endings click the button  (or click Connectors, stoppers on context menu). Set your 

desired pipe endings in the Connections, stoppers dialog box. 

 

  
 

Examples: 

 
 

Using the pipes and settings in the Connectors, stoppers dialog box, you can easily create pipe elements. For 

example, 
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For pipe without diameter, the set of connectors and limiters is different. In the Connectors, stoppers dialog 

box, you can specify a size that determines the height of the constraints and the elements that can be placed 

on the pipe. 

 

  
 

7. To center and bind the object located on the pipe to the pipe itself, click the button   (or click Align > 

Align to Pipe and Attach on context menu). 

 

  
 

 

 

8. Some objects (for example, a pressure gauge or temperature sensor) can be tied to the border (surface) of 

the pipe. Click the button . To change the type of the mounting click the button  (or click Mounting on 

context menu). Set your desired mounting in the Mounting dialog box. 

 

Size  
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In addition, to visualize the installation there are special "mounting" elements. They are located in the 

Measurement section.  

 

 
 

 

Below is an example of both methods for mounting sensors. 

 

 
 

 

1. Click Align to Pipe and 

Attach button 

2. If desired, change 

the type of mounting 
of the object to the 

pipe 

“Mounting” element 

The result of the setup in the 

Mounting dialog box 
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9. To set the object size by pipe diameter, click the button  (or click Align > Set Object Size by Pipe 

Diameter on context menu). You can also press the button  (located to the right of the button ) to set 

object size by pipe diameter with the multiplication factor. 
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Colors 
 

1. For most objects, you can set two or three primary colors: one for the fill, one for the border, and third 

(optional) color, depending on the object type. For example, you can only specify two colors for a heating 

radiator: fill color and border color. However, for example, you can set three colors for a rectangle with text: 

fill color, border color, and text color. You can also set three colors for the monitor: fill color, border color, 

and screen color. 

 

 

 
 

 

2. For objects that have flanges or screw-nuts, you can change the color of the flanges or screw-nuts. To 

change the color, type, width, height and gasket of flanges click the button . To change the color, type, 

width, height of flanges of screw-nuts click the button . Set your desired properties in the pop-up dialog 

box. 

 

 

 

 

 

 

For example, we have changed 

the color and type of flanges 

Fill Lines Additional color 

Additional color: 

text color 

Additional color: 

screen color No additional color 

no 
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3. The color of individual pipe segments, the color of pipe nodes, the color of the insulation can be set in the 

Nodes and diameter dialog box. Click the button  (or click Nodes and Diameter on context menu) to show 

the Node and diameter dialog box. 

 

 
 

4. If you want to create a monochrome scheme, you do not need to change the colors of each object. Just 

select the color scheme in the Picture properties dialog box (click the button  to show the dialog box). In 

the same dialog box, you can set the background color. 

 

  
 

1 Choose, for example, 

"Black-white” 

2. The image became "black 

and white” 
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The program contains 9 color themes that define the fill colors and lines of objects. In addition, the user can 

set his color theme. Themes, except “Color and volume”, are monochrome. Choice of the theme does not 

affect the background color. 

 

 

 
Color and volume 

 

 

 
Black-white 

 

 
Lemon 

 

 
Cowberry 

 

 

 
Kiwi 

 

 
Bog bilberry 

 

 
Pomegranate 

 

 

 
Coffee 

 

 
Bilberry 
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Text 
 

To enter the text for the selected object, click the button  or button  to display the corresponding dialog 

box. The buttons  and  cannot be on the screen at the same time. The button  is available for objects 

for which you can set text and attributes of text: font, size, alignment, color. The button  is available only 

for objects for which you can set only text. 

 

 

 

 

After entering the text, be sure to click on the button , otherwise the text will not be saved. If the 

Stretchable text check box is selected, the font size does not matter, the text size will depend on the size of 

the object. 

After entering the text, press this 
button, otherwise the text will not be 

saved 
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Each scheme in Easymnemo can contain 5 variants of text and comments. This feature is implemented in 

order to have the same scheme “in several languages”. Try to change the Text and comments language in 

some example Easymnemo, and there is an impression that the program itself has translated the scheme into 

another language. 

 

The Text and comments language for the diagram can be set in the Picture Properties dialog box (click the 

button  to show the dialog box). 

 

Note: The language settings for the scheme are conditional. For example, you can set Text and comments 

language to Spanish, but you can type text in English. 

 

  
 

 

Note: For “Meter reading device” objects (Figures/Text) the text format is “White Digits/Point/Red Digits” 

and defines the appearance of the object. For example, 

 

In the example, English was installed and the entire 

text became "English” 
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Comments 
 

A comment is text that can be bound to any object and is displayed along one of the object's boundaries. 

 

The text, font, color, position relative to the object, as well as the fill and border of the rectangle within 

which the comment is displayed can set in the Comment dialog box. To open the dialog box, click the button 

 (or click Comment on context menu). 

 

 
 

Note: When you change the size of the object, the font size does not change. 
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Specification 

 

A specification is a summary table of the objects that you have drawn and that you would like to see in this 

table (or, most likely, a part of them) with automatic calculation of the number of identical objects. To do 

this, each object must be described in the Specification dialog box (to show dialog box click the button or 

click Specification on context menu). For example, 

 
 

After you have set the specification of objects, add the Specification object (Forms section) to the 

schema

 
 

The fields of the summary table can be edit in the Specification (Style) dialog box (click the button  to 

show the dialog box) 

 
 

You can save the specification to the file (for later usage, for example, in Excel) click Export of specification 

to CSV on context menu. 

 

Note: Easymnemo contains a Specification example that will simplify the understanding of how to create 

specifications. 
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Models 
 

Models are items that you can create yourself. When developing a model, you can use any elements from 

any section. 

 

Note: To create models, the Details subsection have been added to the Shapes/Text section. 

 

To create a model, follow these steps: 

 

1. Add to the diagram the objects from which the model will be composed. 

2. Set your desired properties (size, fill, border, text, etc) of objects. 

3. Compose (place) objects to get the intended result. 

4. Select objects and click the button -Assemble model (or click Model > Assemble model on context 

menu). 

 
5. In the dialog box set the name of the model. After that, a new model will appear in the Models 

section. 

 

Models are stored as separate files in the Models folder of the Easymnemo installation directory (by default 

C:\Program Files (x86)\Easymnemo). When you install Easymnemo on another computer, to transfer “your” 

models, just copy the Models folder. The file names are the same as the model names. 

 

There are no restrictions to select objects. Generally speaking, you can make a model from the whole 

scheme. Click on context menu of the model button to rename, delete or preview model. 

 

 
 

To edit the created model, you need to add the model to the diagram, disassemble it ( -Disassemble the 

model), make changes and assemble again. Deleting or changing a model does not affect models already 

added to the schema. 

 

Inserting an object from the Model panel is different from inserting objects from other panels. After 

activating the desired button on the Model panel, simply click the left mouse button on the diagram (you do 

not need to ”pull" the mouse pointer). The object added to the diagram will have dimensions and position 

exactly the same as the model has when it is built. Therefore, the position of the cursor does not matter. 
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Note: Easymnemo contains examples that explain the process of creating the models: 

 

 
 

 

Isometric projection 
 

Starting from version 2.19.08.22 Easymnemo can to draw objects in isometric projection. This possibility is 

provided for most of the objects of the technical standards (GOST, ABOK, etc.), buildings, doors, windows 

and the element Interval. 

 

To create a geometric projection, select the object and click the button . Then set the Projection angle in 

the dialog box. 

 
Note: It is possible that the binding to the pipes of such objects will not work or will not work correctly. 
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User panels 
 

As the library of elements is constantly updated and it becomes more difficult to find the necessary element 

in the Easymnemo program there is an opportunity to the user to create the panels (to 5 panels) in which he 

can add any elements from other panels or from the ready diagram. 

 

To add a new user panel, in the Settings menu click Add User Panel. 

 

 
 

 

Then in the dialog box enter the name of the panel. For example, Heat: 

 

 
 

 

As a result, the panel name should appear to the right of the Model panel: 

 

  
 

To change the name of the panel or delete the panel click the desired item on context menu: 
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You can add an item to the user panel in one of two ways. 

 

1. Select the desired element icon on one of the panels and then click "Panel name" on the context menu 

Copy to the user panel: 

 

 
 

 

2. Select one or more objects in the diagram and click Copy to User Panel > “Panel name" on context menu: 

 

 
 

User panels are stored in the User panels folder of the Easymnemo installation directory (by default 

C:\Program Files (x86)\Easymnemo). When you install Easymnemo on another computer, to transfer “your” 

user panels, just copy the User panels folder. 
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Export to bitmap files (BMP, GIF, JPEG, PNG, TIFF) 
 

In the File menu, click Export.  

 

 

Inserting bitmap files (BMP, GIF, JPEG, PNG, TIFF) 

To insert an image from a file, use the icon  (Shapes/Text section).  

 

 

Examples 
 

Easymnemo contains more than 100 examples. In the File menu, click Examples to open the Examples 

window.  

 

 

Recommendations 
 

1. By default, the line color is black and the thickness is 1 px. However, sometimes the image looks more 

attractive if the color of the lines for the object borders is set to the color of the object fill, and the thickness 

of the lines is set to less than 1 px (the latter is relevant for printing). 

 

  
 

The color and thickness of the lines are set in the Lines dialog box. Click the button  (or click Lines on 

context menu) to open the Lines dialog box. 

 

2. When resizing, hold down the Shift key to keep the proportions of the object. 

 

3. To nudge a object exactly one pixel, hold down Shift key and press an arrow key. To resize a object 

exactly one pixel, hold down Shift and press + (to increase width) or – (to reduce width) or PageUp (to 

increase height) or PageDown (to reduce height). 

 

4. To quickly copy the properties of one object to another, use the button - Format Painter. Allows you to 

copy from one object to another the properties of the fill, borders, shadows, text and comment. For pipes 

also the diameter, properties of nodes and insulation. 

 

Change 

border color  
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5. Use the Search dialog box to search for an item (the Search menu at the top right of the program window). 

In the search bar, you can enter words from the descriptions of the item icons or enter a technical standard. 

For example, 

 

 
 

6. Double-click a polyline, pipe, or duct to align "not enough horizontal and vertical" segments. 

"Insufficient” means a deviation of less than 5 degrees from the horizontal or vertical. The picture below 

shows the result of this “trick”. 

 
 

7. Two pipes or lines can be combined into one. To do this, select the desired pipes/lines and select Merge 

Lines/Pipes on context menu. 

 

 

 

 

 

 


